SnapStream Forums

Go Back   SnapStream Forums > SnapStream Developer Network > Beyond TV Downloads
Register FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Rating: Thread Rating: 44 votes, 4.84 average. Display Modes
  #76  
Old 08-25-2005, 08:09 AM
jsereda jsereda is offline
Registered User
 
Join Date: Mar 2004
Posts: 215
Re: [addon] AutoXvid (Aug 18 Update)

Lee,

Im pretty sure I have WaitForSmartChapters set to No. Also these are files I have already cut the commercials out of so there is no smart chapter xml file.
I will work on this a little more when I get home today.
__________________
ATI P4R800V Delux / P4 3.06 533FSB / 1 gig DDR Dual Channel Mode / 500 Watt Power Supply / (2) 160gig Raid 0 for recording / (1) 200gig to store Divx files / (1) 160gig OS drive / (1) PVR250 via Coax / (1) PVR150 via Digi Cable box / USB UIRT / ATI Remote Wonder / Lian Li Case / BTV 3.5.3 / XP Pro
Reply With Quote
  #77  
Old 08-25-2005, 08:37 AM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Re: Mrs

Quote:
Originally Posted by neekap
Alrighty, I just finished encoding a file by dragging and dropping, and the .log file has been sitting in D:\ for over 5 minutes now.

So in the root of D: I have MXC-(College Girls)-2005-06-30-0.avi and MXC-(College Girls)-2005-06-30-0_agk.log, both appear to be "normal" and these are the last entries in my autoxvid.log file:

2005-08-24 17:43:01 : AutoXvid: D:\TV\MXC-(College Girls)-2005-06-30-0.mpg
2005-08-24 17:43:01 : OutPutSize SB Quality 30%
2005-08-24 17:43:02 : EpisodeData exported episode data into D:\TV\MXC-(College Girls)-2005-06-30-0.xml
2005-08-24 17:43:05 : Final Path=D:\TV MakeSubDir=0 DeleteSource=0 EpisodeData+1 Shutdown=0 Chapters=0
2005-08-24 17:43:05 : AutoXvid Qued D:\TV\MXC-(College Girls)-2005-06-30-0.mpg to AutoGK

Also, AgKnot stays open and the hourglass icon still remains in the system tray. I did not touch anything after dragging the mpg to the autoxvid icon.

This is the same issue I was having prior, in terms of manual dragging and dropping. I haven't tested BTV doing a recording and seeing if it takes off from there, yet. At this point all I need to do is move the avi into the D:\TV folder, drag the mpg to the metadataextractor then do the same with the avi, then delete the mpg.

Suggestions?
If you clean up manually, stop ScheduledRun and delete DiskQue.txt from the folder where you installed AutoXvid. Also delete ROOT:\agk_tmp dir
Meanwhile: I have obligations for most of the day, when I get back, I need to do some DRAG/DROP testing without WaitForSmartChapters
and see if I have a problem. I have long since converted all my files to Xvid and deleted the mpgs, so I haven't done much of that.
Lee Cole
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en
Reply With Quote
  #78  
Old 08-25-2005, 09:01 AM
neekap neekap is offline
Registered User
 
Join Date: Mar 2005
Posts: 39
Re: Mrs

Quote:
Originally Posted by leecole
If you clean up manually, stop ScheduledRun and delete DiskQue.txt from the folder where you installed AutoXvid. Also delete ROOT:\agk_tmp dir
Meanwhile: I have obligations for most of the day, when I get back, I need to do some DRAG/DROP testing without WaitForSmartChapters
and see if I have a problem. I have long since converted all my files to Xvid and deleted the mpgs, so I haven't done much of that.
Lee Cole
Lee:

I saw this problem after I "cleaned up" for the night. When this last recording started, there was no DiskQue.txt file nor ScheduledRun running. Top Gear recorded, and the avi got created in the root and that's the end. Therefore I'm seeing these symptoms whether I'm manually converting files or autoxvid is running automatically when the recording is completed from BTV.
Reply With Quote
  #79  
Old 08-25-2005, 11:39 AM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by neekap
Lee:

I recorded Top Gear on the Discovery channel last night. Autoxvid did create the avi in the root but didn't do anything beyond that. I have the avi and the log in the root of D, and that single entry in the diskque.txt. I'll be out during the day today, but can you give me some troubleshooting steps for later this afternoon?

Thanks,
OK, you guys have convinced me that there's something wrong with ScheduledRun that doesn't show up with my parameters but does with yours. I will do some testing.
Lee Cole
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en
Reply With Quote
  #80  
Old 08-25-2005, 11:51 AM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by ThickHead
Lee,
I'm in exactly the same situation as neekap, the .avi and AuoGK.log are finished and sitting in the root while ScheduledRun sits idling away in the tray indefinitely.

I noticed something is up with OutPutFolder in the .ini, if I leave a space between "=" and the desired path name:
i.e. "OutPutFolder= D:\Video\MP4"
I get an undesired new folder created with a name of "D:\Video\MP4Not Found"
If I don't leave that space character between there:
i.e. "OutPutFolder=D:\Video\MP4"
then the undesired folder is not created.

Is it possible that one problem might be that ScheduledRun is not parsing the .ini correctly and it's making it hang? Thanks again for your effort and responsiveness!
You must be using MakeSubDir, what format? Genre ot Title?
The reason it worked one time and failed another, isn't because of the leading space, it is because BTV didn't know the Genre or Title, whichever you were using, and I had previouslly initilized the field to "Not Known'. I know how to fix the Title, but I don't know what do do about Genre. In most cases, the Title is the Series name, except for News and Movies.
I will work on this.
I can count on you to find um. You missed your calling.
Lee Cole
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en
Reply With Quote
  #81  
Old 08-25-2005, 01:30 PM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Thumbs up Re: [addon] AutoXvid (Aug 18 Update)

Jsereda, Neekap, ThickHead
Here's the fix. I was finally able to reproduce the problem. I think you three are at a safe level to apply this fix, anyone else should verify that they are at V1.0.3.0 of AutoXvid package before using this module. You can check what Version you are at by selecting the icon
of ScheduledRun.exe (or AutoXvid.exe) and right click- select properties - select version. It should read 1.0.3.0. If it doesn't goto first post of this thread and download the RAR AutoXvid and apply first before replacing that ScheduledRun.exe with this one. I am not sure, but this appears to be a AutoIt Beta problem:
If $Chapters Then
I had to replace this with
If $Chapters==1 Then
Anyway, I was able to verify that this did take care of the problem. I was never seeing it because I always run with WaitForSmartChapters= Yes and all of you were running with No.
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en

Last edited by leecole; 12-06-2007 at 06:09 AM.
Reply With Quote
  #82  
Old 08-25-2005, 04:01 PM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by ThickHead
Lee,
I noticed something is up with OutPutFolder in the .ini, if I leave a space between "=" and the desired path name:
i.e. "OutPutFolder= D:\Video\MP4"
I get an undesired new folder created with a name of "D:\Video\MP4Not Found"
If I don't leave that space character between there:
i.e. "OutPutFolder=D:\Video\MP4"
then the undesired folder is not created.
ThickHead,
Here's my thought on what happened. I suspect you drag-drop from a non BTV folder and had MakeSubDir=Yes. AutoXvid attempted to get Gende and Title
from Beyond TV and request was rejected. AutoXid makesubdir returned "Not Known" but the calling code was expecting "\Sub Dir Name" . I have changed the code so that instead of returning "Not Known" it will use the Series name if it is a Series (name is Series-(Episode Name)-date.mpg), if not a series, but a TV special or a movie (name Movie Title-date.mpg) it will return the Movie Title.
I also preceed it with the "\" so you will get Subdir built with either SERIRS name (SeinFeld) or a Movie or documentry title.

Again: Before applying this exe, right click on AutoXvid.exe, select properties,
select version. The version should be 1.0.3.0 if not obtain the AutoXvid.rar from the first entry of this AutoXvid forun, unpack it to your AutoXvid folder, then replace AutoXvid.exe with this one.
Lee Cole
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en

Last edited by leecole; 12-06-2007 at 06:09 AM.
Reply With Quote
  #83  
Old 08-25-2005, 06:32 PM
neekap neekap is offline
Registered User
 
Join Date: Mar 2005
Posts: 39
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by leecole
Jsereda, Neekap, ThickHead
Here's the fix. I was finally able to reproduce the problem. I think you three are at a safe level to apply this fix, anyone else should verify that they are at V1.0.3.0 of AutoXvid package before using this module. You can check what Version you are at by selecting the icon
of ScheduledRun.exe (or AutoXvid.exe) and right click- select properties - select version. It should read 1.0.3.0. If it doesn't goto first post of this thread and download the RAR AutoXvid and apply first before replacing that ScheduledRun.exe with this one. I am not sure, but this appears to be a AutoIt Beta problem:
If $Chapters Then
I had to replace this with
If $Chapters==1 Then
Anyway, I was able to verify that this did take care of the problem. I was never seeing it because I always run with WaitForSmartChapters= Yes and all of you were running with No.
Still no dice

I can close and reopen scheduledrun.exe and in the pop up balloon it says searching for the correct log file in D:\ (no I can't remember it verbatim, but the file path and name did match perfect) and is stuck in the "Encode 1" state. The DiskQue.txt only contains that one show.
Reply With Quote
  #84  
Old 08-25-2005, 07:04 PM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by neekap
Still no dice

I can close and reopen scheduledrun.exe and in the pop up balloon it says searching for the correct log file in D:\ (no I can't remember it verbatim, but the file path and name did match perfect) and is stuck in the "Encode 1" state. The DiskQue.txt only contains that one show.
I'm not understanding. Does the pop up balleon pop up every 5 minutes? The hover message that tells how many encodes are queued shows all the time, if you hover the mouse over the icon. But SchdledRun should wake up every 5 minutes to check for the AutoGK log. Or, are you saying that the AutoGK log is there and the AVI file hasn't been moved?
Lee Cole
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en
Reply With Quote
  #85  
Old 08-25-2005, 07:17 PM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by neekap
Lee,

I just upgraded to AutoGK 2.16 beta, installed the update to autoxvid and I broke it.

Edit/Update: I don't know what happened in AutoGK 2.16, but it's all messed up. I pulled an old copy of 2.15b at http://www.free-codecs.com/AutoGK_download.htm since AutoGK doesn't keep their older beta releases anywhere I could find them and it started the process. Now I just need to cross my fingers and see if it completes it
When you reported this, I went and got AutoGK 2.16 too. At first, I had no problem with it, but after encoding a frw files, it suddenly froze. It didn't seem to be in a loop, no cpu cycles, but it wouldn't respond. Had to use taskmanager to take it down. After that, I could never get it to work again, either through AutoXvid or manually. I too had to go back to 2.15.
Lee Cole
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en
Reply With Quote
  #86  
Old 08-25-2005, 08:44 PM
jsereda jsereda is offline
Registered User
 
Join Date: Mar 2004
Posts: 215
Re: [addon] AutoXvid (Aug 18 Update)

Lee the scheduled run.exe fix you posted worked great from what I can tell thus far.

I do have another suggestion (Im sure you already thought of it too )but have you considered an ad cut portion to this? I mean during the first step, you could have autoxvid launch igcutter and save the cut mpeg into the temp directory to encode. The final encoded avi would be ad free, well somewhat, i know smart chapters arent perfect. But it would reduce size even more for those wanting to save on disk space. Igcutter also saves the show data into the mpeg, so you could extract it from there as well.

I know your busy with OPP's so I'll stop jabbering, and you probably dont want to rebuild the program anyway.
Anyway great work. I'm really enjoying this program.
__________________
ATI P4R800V Delux / P4 3.06 533FSB / 1 gig DDR Dual Channel Mode / 500 Watt Power Supply / (2) 160gig Raid 0 for recording / (1) 200gig to store Divx files / (1) 160gig OS drive / (1) PVR250 via Coax / (1) PVR150 via Digi Cable box / USB UIRT / ATI Remote Wonder / Lian Li Case / BTV 3.5.3 / XP Pro
Reply With Quote
  #87  
Old 08-25-2005, 09:02 PM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by jsereda
Lee the scheduled run.exe fix you posted worked great from what I can tell thus far.

I do have another suggestion (Im sure you already thought of it too )but have you considered an ad cut portion to this? I mean during the first step, you could have autoxvid launch igcutter and save the cut mpeg into the temp directory to encode.
Anyway great work. I'm really enjoying this program.
I did consider this at one time, but at that time when I tried igcutter, I lost all
episode data, if igcutter has done something about that, maybe I should look at it again.
Lee Cole
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en
Reply With Quote
  #88  
Old 08-26-2005, 08:43 AM
neekap neekap is offline
Registered User
 
Join Date: Mar 2005
Posts: 39
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by leecole
I'm not understanding. Does the pop up balleon pop up every 5 minutes? The hover message that tells how many encodes are queued shows all the time, if you hover the mouse over the icon. But SchdledRun should wake up every 5 minutes to check for the AutoGK log. Or, are you saying that the AutoGK log is there and the AVI file hasn't been moved?
Lee Cole
Yes, the balloon still pops up every 5 minutes. It's almost like it doesn't see the log file sitting there. The AVI file hasn't moved, AGKnot doesn't close, and the xml information has not merged into the avi yet.
Reply With Quote
  #89  
Old 08-26-2005, 09:38 AM
leecole's Avatar
leecole leecole is offline
l33t Member
 
Join Date: Nov 2002
Location: Cary, NC
Posts: 2,614
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by neekap
Yes, the balloon still pops up every 5 minutes. It's almost like it doesn't see the log file sitting there. The AVI file hasn't moved, AGKnot doesn't close, and the xml information has not merged into the avi yet.
OK, I'm running out of ideas. Let's look for the easy answer first. As soon as you can, right click on ScheduledRun.exe icon in AutoXvid's die. select Properties, select Version and post what it says. If it still exits post contents of DiskQue.txt and AutoXvid.log.
Maybe I will see something.
Lee Cole
__________________
Lee L. Cole
Sometimes I sits and thinks
and sometimes, I just sits

AUTOXVID - Check this out:
AutoXvid Manual -
http://docs.google.com/Doc?docid=0AU...dHc2Y2Q4&hl=en
Reply With Quote
  #90  
Old 08-26-2005, 10:31 AM
neekap neekap is offline
Registered User
 
Join Date: Mar 2005
Posts: 39
Re: [addon] AutoXvid (Aug 18 Update)

Quote:
Originally Posted by leecole
OK, I'm running out of ideas. Let's look for the easy answer first. As soon as you can, right click on ScheduledRun.exe icon in AutoXvid's die. select Properties, select Version and post what it says. If it still exits post contents of DiskQue.txt and AutoXvid.log.
Maybe I will see something.
Lee Cole
ScheduledRun.exe is 1.0.3.0

DiskQue.txt:

Scrubs-(My Unicorn)-2005-08-25-0.mpg|D:\TV|D:\TV|0|0|1|0|0
Scrubs-(My Ocardial Infarction)-2005-08-25-0.mpg|D:\TV|D:\TV|0|0|1|0|0

autoxvid.log:

2005-08-25 21:31:05 : __________________________________________________ __________________________________________________ ___________
2005-08-25 21:31:05 : AutoXvid: D:\TV\Scrubs-(My Unicorn)-2005-08-25-0.mpg
2005-08-25 21:31:05 : OutPutSize SB Quality 30%
2005-08-25 21:31:06 : EpisodeData exported episode data into D:\TV\Scrubs-(My Unicorn)-2005-08-25-0.xml
2005-08-25 21:31:11 : Final Path=D:\TV MakeSubDir=0 DeleteSource=0 EpisodeData+1 Shutdown=0 Chapters=0
2005-08-25 21:31:11 : AutoXvid Qued D:\TV\Scrubs-(My Unicorn)-2005-08-25-0.mpg to AutoGK
2005-08-25 22:02:34 : __________________________________________________ __________________________________________________ ___________
2005-08-25 22:02:34 : AutoXvid: D:\TV\Scrubs-(My Ocardial Infarction)-2005-08-25-0.mpg
2005-08-25 22:02:34 : OutPutSize SB Quality 30%
2005-08-25 22:02:36 : EpisodeData exported episode data into D:\TV\Scrubs-(My Ocardial Infarction)-2005-08-25-0.xml
2005-08-25 22:02:42 : Final Path=D:\TV MakeSubDir=0 DeleteSource=0 EpisodeData+1 Shutdown=0 Chapters=0
2005-08-25 22:02:42 : AutoXvid Qued D:\TV\Scrubs-(My Ocardial Infarction)-2005-08-25-0.mpg to AutoGK

And currently in D:\ I have the .avi and the .log for each of those programs.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[plugin] POP3/SSL Email (November 5 Update) SSDNAdmin Beyond Media Downloads 149 12-21-2012 08:58 AM
[plugin] Web Videos (November 27 Update) SSDNAdmin Beyond Media Downloads 111 11-01-2007 07:30 AM
[plugin] BTV Status (ON HOME SCREEN!) (November 9 Update) SSDNAdmin Beyond Media Downloads 41 01-25-2006 01:11 AM
BTV4 Skin Development Templates (November 28 Update) SSDNAdmin Beyond TV Downloads 7 11-28-2005 09:17 AM


All times are GMT -6. The time now is 02:29 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
©2004-2009 Snapstream Media
You Rated this Thread: